# CVE-2026-108764: Apache Kylin: job-driver UI proxy SSRF

> An SSRF vulnerability in Apache Kylin's job-driver UI proxy allows attackers to make arbitrary server-side requests, primarily affecting publicly exposed deployments.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-c56v-vw4p-2ff3

## What is CVE-2026-108764?

CVE-2026-108764 is a server-side request forgery vulnerability in Apache Kylin, published on 19 Oct 2026. It can be exploited over the network, with no action from the victim.

### Official description

Server-Side request forgery (SSRF) vulnerability in Apache Kylin. Impact most to the kylin job service that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted.

This issue affects Apache Kylin: from 4.0.0 through 5.0.4.

Users are recommended to upgrade to version 5.0.5, which fixes the issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-108764?


## How do I fix CVE-2026-108764?

No fix has been published for CVE-2026-108764 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-108764 being exploited?

There is no known exploitation of CVE-2026-108764 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-108764 and fix it if it is affected.

What it is: CVE-2026-108764 is a server-side request forgery vulnerability in Apache Kylin, published on 19 Oct 2026. It can be exploited over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-108764 in the wild and no public exploit code.

Affected product: Apache Kylin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-108764/ (Markdown: https://insights.sbomify.com/CVE-2026-108764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-108764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-108764
- OSV: https://osv.dev/vulnerability/CVE-2026-108764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-108764/
Summaries are generated and may contain mistakes; the official description above is the record.
