CVE-2026-108771 Apache Kylin: unauthenticated broadcast API and polymorphic deserialization
Unauthenticated polymorphic deserialization in Apache Kylin allows remote code execution on publicly exposed services.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-108771?
CVE-2026-108771 is an unsafe deserialization vulnerability in Apache Kylin, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Missing authentication for in-house broadcast and polymorphic deserialization vulnerability in Apache Kylin. Impact most to the kylin services that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted.
This issue affects Apache Kylin: from 4.0.0 through 5.0.4.
Users are recommended to upgrade to version 5.0.5, which fixes the issue.
Weakness: CWE-306
Which versions are affected by CVE-2026-108771?
How do I fix CVE-2026-108771?
No fix has been published for CVE-2026-108771 yet. Limit exposure of the affected software until one is available.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-108771 being exploited?
There is no known exploitation of CVE-2026-108771 in the wild and no public exploit code.
Sources
Also known as GHSA-8p62-58r2-prmw.