# CVE-2026-108780: Apache Kylin: Potential JDBC source configuration validation issue

> An attacker with high privileges can bypass JDBC source configuration validation in Apache Kylin, potentially exposing backend services if publicly accessible.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-347f-x236-v6hm

## What is CVE-2026-108780?

CVE-2026-108780 is a vulnerability in Apache Kylin, published on 19 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Potential JDBC source configuration validation vulnerability in Apache Kylin. The impact is minor, unless the kylin backend services are open to public network.

This issue affects Apache Kylin: from 4.0.0 through 5.0.4.

Users are recommended to upgrade to version 5.0.5, which fixes the issue.

## Which versions are affected by CVE-2026-108780?


## How do I fix CVE-2026-108780?

No fix has been published for CVE-2026-108780 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-108780 being exploited?

There is no known exploitation of CVE-2026-108780 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-108780 and fix it if it is affected.

What it is: CVE-2026-108780 is a vulnerability in Apache Kylin, published on 19 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-108780 in the wild and no public exploit code.

Affected product: Apache Kylin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-108780/ (Markdown: https://insights.sbomify.com/CVE-2026-108780/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-108780
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-108780
- OSV: https://osv.dev/vulnerability/CVE-2026-108780

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-108780/
Summaries are generated and may contain mistakes; the official description above is the record.
