CVE-2026-108822 Kamailio sipt ss7_parser.c isup_get_calling_party buffer overflow
Remote attackers can trigger a buffer overflow in Kamailio's sipt module via crafted SS7 messages, potentially leading to code execution or service disruption.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-108822?
CVE-2026-108822 is a medium-severity memory corruption vulnerability in Kamailio, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A vulnerability was detected in Kamailio up to 6.0.7/6.1.3. The affected element is the function isup_get_calling_party of the file src/modules/sipt/ss7_parser.c of the component sipt Module. The manipulation of the argument length results in buffer overflow. The attack may be performed from remote. Upgrading to version 6.0.8 and 6.1.4 is sufficient to fix this issue. The patch is identified as 3667bebf8d0bea07ed16218fd921d07db87aeb21. Upgrading the affected component is advised.
Which versions are affected by CVE-2026-108822?
How do I fix CVE-2026-108822?
No fix has been published for CVE-2026-108822 yet. Limit exposure of the affected software until one is available.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-108822 being exploited?
There is no known exploitation of CVE-2026-108822 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2026-108822, GHSA-8639-687x-5rvv, UBUNTU-CVE-2026-108822.