# CVE-2026-108836: Ollama Pull API name.go IsValid server-side request forgery

> Remote attackers can exploit a flaw in the Ollama Pull API to perform server-side request forgery, potentially accessing internal resources.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-fr42-jr2w-mx59

## What is CVE-2026-108836?

CVE-2026-108836 is a medium-severity server-side request forgery vulnerability in Ollama, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability has been found in Ollama up to 0.34.1. The affected element is the function IsValid of the file types/model/name.go of the component Pull API. The manipulation leads to server-side request forgery. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.34.2 is sufficient to fix this issue. The identifier of the patch is dfabde4539e42ba1e1eab50a3a50b88aea7958a0. It is suggested to upgrade the affected component.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-108836?


## How do I fix CVE-2026-108836?

No fix has been published for CVE-2026-108836 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-108836 being exploited?

There is no known exploitation of CVE-2026-108836 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-108836 and fix it if it is affected.

What it is: CVE-2026-108836 is a medium-severity server-side request forgery vulnerability in Ollama, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-108836 in the wild and no public exploit code.

Affected product: Ollama. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-108836/ (Markdown: https://insights.sbomify.com/CVE-2026-108836/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-108836
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-108836
- OSV: https://osv.dev/vulnerability/CVE-2026-108836

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-108836/
Summaries are generated and may contain mistakes; the official description above is the record.
