CVE-2026-108837 Apache Kylin: Potential computed-column resource exhaustion
A project admin can cause resource exhaustion in Apache Kylin via a cache API, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-108837?
CVE-2026-108837 is a denial of service vulnerability in Apache Kylin, published on 19 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Allocation of resources without limits or throttling vulnerability in Apache Kylin. Given an attacker has got project admin permission, an cache API maybe used to cause computed-column resource exhaustion.
This issue affects Apache Kylin: from 4.0.0 through 5.0.4.
Users are recommended to upgrade to version 5.0.5, which fixes the issue.
Weakness: CWE-770
Which versions are affected by CVE-2026-108837?
How do I fix CVE-2026-108837?
No fix has been published for CVE-2026-108837 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-108837 being exploited?
There is no known exploitation of CVE-2026-108837 in the wild and no public exploit code.
Sources
Also known as GHSA-rfxx-8jfp-h6qv.