CVE-2026-1090 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.7 Published Updated

Authenticated users can inject JavaScript via markdown placeholders when the feature flag is enabled, potentially leading to code execution or account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-1090?

CVE-2026-1090 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 11 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.6 before 18.7.6, 18.8 before 18.8.6, and 18.9 before 18.9.2 that could have allowed an authenticated user, when the `markdown_placeholders` feature flag was enabled, to inject JavaScript in a browser due to improper sanitization of placeholder content in markdown processing.

Weakness: CWE-79

Which versions are affected by CVE-2026-1090?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.6.018.7.6, 18.8.6, 18.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-1090?

Upgrade gitlab to a fixed version for your release line: 18.7.6, 18.8.6 or 18.9.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-1090 being exploited?

There is no known exploitation of CVE-2026-1090 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-1090, GHSA-qv6p-pfj5-mhj9, UBUNTU-CVE-2026-1090.

Is CVE-2026-1090 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free