CVE-2026-1092 Improper Validation of Specified Quantity in Input in GitLab

High 7.5 Published Updated

An unauthenticated attacker can cause a denial of service in GitLab by sending improperly validated JSON payloads.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-1092?

CVE-2026-1092 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 8 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 12.10 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that could have allowed an unauthenticated user to cause denial of service due to improper input validation of JSON payloads.

Weakness: CWE-1284

Which versions are affected by CVE-2026-1092?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.10.018.8.9, 18.9.5, 18.10.3

Products include Gitlab Gitlab.

How do I fix CVE-2026-1092?

Upgrade gitlab to a fixed version for your release line: 18.8.9, 18.9.5 or 18.10.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-1092 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1092 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-1092, GHSA-rp75-jg2c-frm4, UBUNTU-CVE-2026-1092.

Is CVE-2026-1092 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free