# CVE-2026-109301: Parse Server before 8.6.95 and 9.0.0 before 9.10.2-alpha.3 Denial of Service via File Pointer Without URL

> Attackers can crash the Parse Server by sending file pointers without URLs, causing uncaught exceptions in Cloud Code or LiveQuery triggers.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2026
- **Updated:** 18 Oct 2026
- **Also known as:** BIT-parse-2026-109301, GHSA-gpr6-gr9g-pfw6, GHSA-rxj9-xm24-7477

## What is CVE-2026-109301?

CVE-2026-109301 is a high-severity denial of service vulnerability in parse-community parse-server, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server before 8.6.95 and 9.0.0 before 9.10.2-alpha.3 does not resolve file references lacking a URL before passing objects to Cloud Code triggers and LiveQuery, causing an uncaught exception that terminates the process. Attackers able to write to a class with Cloud Code save, find, or delete triggers or LiveQuery enabled, including unauthenticated users when public write access or sign-up is allowed, can crash the server or break subsequent requests.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-109301?

1 open source package ship an affected version, including parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse` | Bitnami | All versions | 8.6.95, 9.10.2 |

## How do I fix CVE-2026-109301?

Upgrade parse to a fixed version for your release line: 8.6.95 or 9.10.2.

## Is CVE-2026-109301 being exploited?

There is no known exploitation of CVE-2026-109301 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-109301 and fix it if it is affected.

What it is: CVE-2026-109301 is a high-severity denial of service vulnerability in parse-community parse-server, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-109301 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse (Bitnami): affected all versions; fixed in 8.6.95, 9.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-109301/ (Markdown: https://insights.sbomify.com/CVE-2026-109301/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-109301
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-109301
- OSV: https://osv.dev/vulnerability/CVE-2026-109301

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-109301/
Summaries are generated and may contain mistakes; the official description above is the record.
