# CVE-2026-109303: Parse Server before 8.6.93 and 9.0.0 before 9.10.1-alpha.13 protectedFields Bypass via Relation Count Query

> Authenticated users can bypass protectedFields restrictions on relation count queries to reveal confidential membership data in Parse Server.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** BIT-parse-2026-109303, GHSA-pq6r-p5vh-4c89, GHSA-rmhf-xv62-rm99

## What is CVE-2026-109303?

CVE-2026-109303 is a medium-severity missing authorization vulnerability in parse-community parse-server, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Parse Server before 8.6.93 and 9.0.0 before 9.10.1-alpha.13 does not enforce identity-scoped protectedFields (authenticated, role, or per-user groups) on count queries using the $relatedTo operator, exposing the size of protected Relation fields. An authenticated user who can read the owning object can combine counts with an objectId constraint as a membership oracle to reveal confidential memberships such as private groups or block lists.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-109303?

1 open source package ship an affected version, including parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse` | Bitnami | All versions | 8.6.93, 9.10.1 |

## How do I fix CVE-2026-109303?

Upgrade parse to a fixed version for your release line: 8.6.93 or 9.10.1.

## Is CVE-2026-109303 being exploited?

There is no known exploitation of CVE-2026-109303 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-109303 and fix it if it is affected.

What it is: CVE-2026-109303 is a medium-severity missing authorization vulnerability in parse-community parse-server, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-109303 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse (Bitnami): affected all versions; fixed in 8.6.93, 9.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-109303/ (Markdown: https://insights.sbomify.com/CVE-2026-109303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-109303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-109303
- OSV: https://osv.dev/vulnerability/CVE-2026-109303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-109303/
Summaries are generated and may contain mistakes; the official description above is the record.
