# CVE-2026-109346: better-auth 1.3.8-beta.3 before 1.7.0-rc.3 Device Authorization Phishing via /device

> Attackers can trick users into approving device authorization requests to steal session tokens due to missing client identification in the UI.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 12 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-q84f-53jg-9ppm, GHSA-v9c8-wq66-wf8g

## What is CVE-2026-109346?

CVE-2026-109346 is a high-severity vulnerability in better-auth, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

better-auth from 1.3.8-beta.3 before 1.7.0-rc.3 contains a UI misrepresentation vulnerability in the deviceAuthorization plugin because GET /device omits the requesting client_id and scope. Attackers can start a device request via /device/code, trick signed-in users into approving the code, then redeem it at /device/token for a live session token.

Weakness: CWE-451 (User Interface (UI) Misrepresentation of Critical Information)

## Which versions are affected by CVE-2026-109346?

2 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | From 1.3.8-beta.3 | 1.7.0-rc.3 |
| `better-auth` | npm | From 1.3.8-beta.3 | 1.7.0-rc.3 |

## How do I fix CVE-2026-109346?

Upgrade better-auth to 1.7.0-rc.3 or later.

## Is CVE-2026-109346 being exploited?

There is no known exploitation of CVE-2026-109346 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-109346 and fix it if it is affected.

What it is: CVE-2026-109346 is a high-severity vulnerability in better-auth, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-109346 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected from 1.3.8-beta.3; fixed in 1.7.0-rc.3
- better-auth (npm): affected from 1.3.8-beta.3; fixed in 1.7.0-rc.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-109346/ (Markdown: https://insights.sbomify.com/CVE-2026-109346/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-109346
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-109346
- OSV: https://osv.dev/vulnerability/CVE-2026-109346

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-109346/
Summaries are generated and may contain mistakes; the official description above is the record.
