CVE-2026-109383 undici vulnerable to TLS certificate validation bypass via dropped tls options in Agent
Attackers can bypass custom TLS certificate validation in undici by exploiting dropped options, allowing acceptance of malicious certificates.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-109383?
CVE-2026-109383 is a high-severity vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici is an HTTP client library for Node.js. In versions 4.0.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its Agent dispatcher passes its constructor options through a JSON-based deep clone before forwarding them to each per-origin pool, and because JSON cannot represent functions, a caller-supplied tls option containing a checkServerIdentity callback is silently dropped before it reaches the TLS layer. As a result, a TLS peer whose certificate a custom checkServerIdentity was written to reject, but which passes Node's default hostname and chain checks, is silently accepted. Because Agent is the default dispatcher behind request, fetch, and setGlobalDispatcher, this affects the path most applications use, and EnvHttpProxyAgent is affected on its direct and no-proxy routes as well, while only applications that pass a function-valued tls option such as a custom checkServerIdentity for certificate or public-key pinning are at risk. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which preserve the tls option outside the JSON clone so custom verification callbacks are forwarded unchanged, and users should upgrade to one of those versions or later. As a workaround, pass the TLS options through connect instead of tls, or for proxied destinations use requestTls and proxyTls.
Weakness: CWE-295
Which versions are affected by CVE-2026-109383?
6 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 4.0.0 | 6.29.1 |
undici npm | From 4.0.0 | 6.29.1 |
undici npm | From 7.0.0 | 7.30.1 |
undici npm | From 7.0.0 | 7.30.1 |
undici npm | From 8.0.0 | 8.12.2 |
undici npm | From 8.0.0 | 8.12.2 |
Products include Nodejs Undici.
How do I fix CVE-2026-109383?
Upgrade undici to a fixed version for your release line: 6.29.1, 7.30.1 or 8.12.2.
Is CVE-2026-109383 being exploited?
There is no known exploitation of CVE-2026-109383 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as CLEANSTART-2026-LA92040, DEBIAN-CVE-2026-109383, ECHO-a72a-81c9-1817, GHSA-2m5v-pch6-74hx, ROOT-APP-NPM-CVE-2026-109383, UBUNTU-CVE-2026-109383.