# CVE-2026-109383: undici vulnerable to TLS certificate validation bypass via dropped tls options in Agent

> Attackers can bypass custom TLS certificate validation in undici by exploiting dropped options, allowing acceptance of malicious certificates.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** CLEANSTART-2026-LA92040, DEBIAN-CVE-2026-109383, ECHO-a72a-81c9-1817, GHSA-2m5v-pch6-74hx, ROOT-APP-NPM-CVE-2026-109383, UBUNTU-CVE-2026-109383

## What is CVE-2026-109383?

CVE-2026-109383 is a high-severity vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici is an HTTP client library for Node.js. In versions 4.0.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its Agent dispatcher passes its constructor options through a JSON-based deep clone before forwarding them to each per-origin pool, and because JSON cannot represent functions, a caller-supplied tls option containing a checkServerIdentity callback is silently dropped before it reaches the TLS layer. As a result, a TLS peer whose certificate a custom checkServerIdentity was written to reject, but which passes Node's default hostname and chain checks, is silently accepted. Because Agent is the default dispatcher behind request, fetch, and setGlobalDispatcher, this affects the path most applications use, and EnvHttpProxyAgent is affected on its direct and no-proxy routes as well, while only applications that pass a function-valued tls option such as a custom checkServerIdentity for certificate or public-key pinning are at risk. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which preserve the tls option outside the JSON clone so custom verification callbacks are forwarded unchanged, and users should upgrade to one of those versions or later. As a workaround, pass the TLS options through connect instead of tls, or for proxied destinations use requestTls and proxyTls.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-109383?

6 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 4.0.0 | 6.29.1 |
| `undici` | npm | From 4.0.0 | 6.29.1 |
| `undici` | npm | From 7.0.0 | 7.30.1 |
| `undici` | npm | From 7.0.0 | 7.30.1 |
| `undici` | npm | From 8.0.0 | 8.12.2 |
| `undici` | npm | From 8.0.0 | 8.12.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-109383?

Upgrade undici to a fixed version for your release line: 6.29.1, 7.30.1 or 8.12.2.

## Is CVE-2026-109383 being exploited?

There is no known exploitation of CVE-2026-109383 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-109383 and fix it if it is affected.

What it is: CVE-2026-109383 is a high-severity vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-109383 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 4.0.0; fixed in 6.29.1
- undici (npm): affected from 4.0.0; fixed in 6.29.1
- undici (npm): affected from 7.0.0; fixed in 7.30.1
- undici (npm): affected from 7.0.0; fixed in 7.30.1
- undici (npm): affected from 8.0.0; fixed in 8.12.2
- undici (npm): affected from 8.0.0; fixed in 8.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-109383/ (Markdown: https://insights.sbomify.com/CVE-2026-109383/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-109383
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-109383
- OSV: https://osv.dev/vulnerability/CVE-2026-109383

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-109383/
Summaries are generated and may contain mistakes; the official description above is the record.
