# CVE-2026-109413: Symfony: Unbounded Recursion in the YAML Inline Lexer Lets a Single Document Crash the Process

> An attacker can crash the application by sending a YAML document with deeply nested inline collections, causing unbounded recursion and stack exhaustion.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** CLSA-2026-1792575614, DEBIAN-CVE-2026-109413, GHSA-2v3c-qxhr-7vpv, UBUNTU-CVE-2026-109413

## What is CVE-2026-109413?

CVE-2026-109413 is a high-severity denial of service vulnerability in sensiolabs symfony, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Symfony YAML prior to versions 5.4.54, 6.4.45, 7.4.18, and 8.1.6, Yaml\Parser::lexInlineStructure() recursed through lexInlineMapping() and lexInlineSequence() for every { and [ of an inline collection, without entering the nesting level that the rest of the parser bounds with maxNestingLevel. A document made of deeply nested inline collections, such as [[[[...]]]], exhausted the stack while it was being lexed: depending on the PHP version and its stack settings, the process crashed or the request ended with a fatal error.

Any code parsing untrusted YAML is affected. That includes #[MapRequestPayload] when the Yaml component is installed and the endpoint does not restrict acceptFormat: a single unauthenticated request with a YAML content type is enough.

This issue affects symfony/yaml through v5.4.53, v6.0.0-BETA1 through v6.4.44, v7.0.0-BETA1 through v7.4.17, and v8.0.0-BETA1 through v8.1.5.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-109413?

16 open source packages ship an affected version, including symfony/symfony and symfony/yaml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/symfony` | Packagist | From 2.0.0 | 5.4.54 |
| `symfony/symfony` | Packagist | From 2.0.0 | 5.4.54 |
| `symfony/symfony` | Packagist | From 6.0.0 | 6.4.45 |
| `symfony/symfony` | Packagist | From 6.0.0 | 6.4.45 |
| `symfony/symfony` | Packagist | From 7.0.0 | 7.4.18 |
| `symfony/symfony` | Packagist | From 7.0.0 | 7.4.18 |
| `symfony/symfony` | Packagist | From 8.0.0 | 8.1.6 |
| `symfony/symfony` | Packagist | From 8.0.0 | 8.1.6 |
| `symfony/yaml` | Packagist | From 2.0.0 | 5.4.54 |
| `symfony/yaml` | Packagist | From 2.0.0 | 5.4.54 |
| `symfony/yaml` | Packagist | From 6.0.0 | 6.4.45 |
| `symfony/yaml` | Packagist | From 6.0.0 | 6.4.45 |
| `symfony/yaml` | Packagist | From 7.0.0 | 7.4.18 |
| `symfony/yaml` | Packagist | From 7.0.0 | 7.4.18 |
| `symfony/yaml` | Packagist | From 8.0.0 | 8.1.6 |
| `symfony/yaml` | Packagist | From 8.0.0 | 8.1.6 |

## How do I fix CVE-2026-109413?

Upgrade symfony/symfony to a fixed version for your release line: 5.4.54, 6.4.45, 7.4.18 or 8.1.6.

## Is CVE-2026-109413 being exploited?

There is no known exploitation of CVE-2026-109413 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-109413 and fix it if it is affected.

What it is: CVE-2026-109413 is a high-severity denial of service vulnerability in sensiolabs symfony, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-109413 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/symfony (Packagist): affected from 2.0.0; fixed in 5.4.54
- symfony/symfony (Packagist): affected from 2.0.0; fixed in 5.4.54
- symfony/symfony (Packagist): affected from 6.0.0; fixed in 6.4.45
- symfony/symfony (Packagist): affected from 6.0.0; fixed in 6.4.45
- symfony/symfony (Packagist): affected from 7.0.0; fixed in 7.4.18
- symfony/symfony (Packagist): affected from 7.0.0; fixed in 7.4.18
- symfony/symfony (Packagist): affected from 8.0.0; fixed in 8.1.6
- symfony/symfony (Packagist): affected from 8.0.0; fixed in 8.1.6
- symfony/yaml (Packagist): affected from 2.0.0; fixed in 5.4.54
- symfony/yaml (Packagist): affected from 2.0.0; fixed in 5.4.54
- symfony/yaml (Packagist): affected from 6.0.0; fixed in 6.4.45
- symfony/yaml (Packagist): affected from 6.0.0; fixed in 6.4.45

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-109413/ (Markdown: https://insights.sbomify.com/CVE-2026-109413/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-109413
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-109413
- OSV: https://osv.dev/vulnerability/CVE-2026-109413

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-109413/
Summaries are generated and may contain mistakes; the official description above is the record.
