{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-109414 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-109414 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-109414 is a medium-severity SQL injection vulnerability in appsbd Vitepos – Point of Sale (POS) for WooCommerce, published on 16 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-109414 and fix it if it is affected.\n\nWhat it is: CVE-2026-109414 is a medium-severity SQL injection vulnerability in appsbd Vitepos – Point of Sale (POS) for WooCommerce, published on 16 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-109414 in the wild and no public exploit code.\n\nAffected product: appsbd Vitepos – Point of Sale (POS) for WooCommerce. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-109414/ (Markdown: https://insights.sbomify.com/CVE-2026-109414/index.md)","id":"CVE-2026-109414","markdown":"https://insights.sbomify.com/CVE-2026-109414/index.md","name":"CVE-2026-109414","record":{"aliases":["GHSA-vx38-3rqc-7pgm"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress POS plugin","requires_auth":"low_privilege","summary":"Authenticated vendors can exploit a SQL injection flaw in the Vitepos plugin to extract sensitive database information via the 'bt' operator.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"The Vitepos – Point of Sale (POS) for WooCommerce plugin for WordPress is vulnerable to blind SQL Injection via the 'src_by[].val.start / src_by[].val.end (operator 'bt')' parameter in all versions up to, and including, 3.6.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with vendor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This is an incomplete fix for a previously patched SQL injection (version 3.6.0), which addressed only the gt/lt/le/ge operators while leaving the 'bt' (BETWEEN) operator branch unpatched.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Vitepos \u003c= 3.6.1 - Authenticated (Vendor+) SQL Injection via 'src_by[].val' Parameter via 'bt' Operator","id":"CVE-2026-109414","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":0,"n_references":7,"next":{"headline":"Adobe Experience Manager | Cross-site Scripting (Stored XSS) (CWE-79)","id":"CVE-2026-109415"},"packages":[],"prev":{"headline":"Symfony: Unbounded Recursion in the YAML Inline Lexer Lets a Single Document Crash the Process","id":"CVE-2026-109413"},"products":["Vitepos – Point of Sale (POS) for WooCommerce"],"published":"2026-10-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-16","vendors":["appsbd"]},"summary":"Authenticated vendors can exploit a SQL injection flaw in the Vitepos plugin to extract sensitive database information via the 'bt' operator.","url":"https://insights.sbomify.com/CVE-2026-109414/"}