{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-109448 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-109448 is a medium-severity vulnerability in PostgreSQL psqlODBC, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-109448 and fix it if it is affected.\n\nWhat it is: CVE-2026-109448 is a medium-severity vulnerability in PostgreSQL psqlODBC, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-109448 in the wild and no public exploit code.\n\nAffected product: PostgreSQL psqlODBC. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-109448/ (Markdown: https://insights.sbomify.com/CVE-2026-109448/index.md)","id":"CVE-2026-109448","markdown":"https://insights.sbomify.com/CVE-2026-109448/index.md","name":"CVE-2026-109448","record":{"aliases":["BELL-CVE-2026-109448","DEBIAN-CVE-2026-109448","GHSA-cmfx-rm3r-p2jr","UBUNTU-CVE-2026-109448","openSUSE-SU-2026:12135-1","openSUSE-SU-2026:22122-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL ODBC driver","requires_auth":"none","summary":"An integer overflow in psqlODBC allows heap memory corruption and potential code execution when binding excessive parameters, affecting applications using the driver.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"},{"id":"CWE-124","name":"Buffer Underwrite"}],"description":"Integer wraparound in psqlODBC SQLBindParameter allows an application, or an attacker who controls how many parameters the application binds on one statement, to corrupt heap memory. psqlODBC stores the binding count in a signed 16-bit field. Binding parameter number 32768 wraps that count to -32768. Binding parameter 32769 then writes about 2.5 MB of zeros starting 1.25 MB before the binding array, which crashes the application or leaves it running on a corrupted heap. Applications that build parameter lists from untrusted input, such as an IN (?, ?, ...) list, are exposed. Versions before psqlODBC 18.00.0005 are affected.","ecosystems":["openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"psqlODBC SQLBindParameter heap memory corruption when binding more than 32767 parameters","id":"CVE-2026-109448","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Symfony: Unbounded Nesting in the Expression Parser Lets Untrusted Expressions Crash the Process","id":"CVE-2026-109449"},"packages":[{"ecosystem":"openSUSE:Leap 16.0","fixed":["18.00.0005-bp160.1.1"],"introduced":["0"],"last_affected":[],"package":"psqlODBC","purl":"pkg:rpm/opensuse/psqlODBC\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:22122-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["18.00.0005-1.1"],"introduced":["0"],"last_affected":[],"package":"psqlODBC","purl":"pkg:rpm/opensuse/psqlODBC\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12135-1"}],"prev":{"headline":"Privilege escalation in User Profile Builder – Beautiful User Registration Forms, User Profiles \u0026 User Role Editor","id":"CVE-2026-109447"},"products":["psqlODBC"],"published":"2026-10-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-16","vendors":["PostgreSQL"]},"summary":"An integer overflow in psqlODBC allows heap memory corruption and potential code execution when binding excessive parameters, affecting applications using the driver.","url":"https://insights.sbomify.com/CVE-2026-109448/"}