# CVE-2026-109829: undici vulnerable to cache poisoning and cross-user disclosure via cross-origin redirects

> Attackers can poison caches or disclose private data via cross-origin redirects in undici when specific interceptor compositions and shared caches are used.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-109829, ECHO-5279-2639-aeaf, GHSA-4w7w-5xrc-9h26, ROOT-APP-NPM-CVE-2026-109829, UBUNTU-CVE-2026-109829

## What is CVE-2026-109829?

CVE-2026-109829 is a high-severity vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici is an HTTP client library for Node.js. In versions 7.0.0 through 7.30.0 and 8.0.0 through 8.12.1, when an originless Agent composes the redirect and cache interceptors in that order with a shared cache store, the cache builds its key from the original request URL before the redirect handler changes the origin, so a response produced after a cross-origin redirect is stored under the original key. An attacker who controls the target of a redirect from a trusted URL can have their response cached under that trusted URL and served to later callers, allowing persistent cache poisoning, and the same key confusion lets a private, non-stored redirect response to a user-specific resource be stored under the original URL and served to a later unauthenticated caller, disclosing private data. Applications are affected only when an originless Agent, a shared cache store, and the redirect-then-cache composition are all used. The issue is fixed in undici 7.30.1 and 8.12.2, which verify the producing origin still matches the cache key and preserve each redirect hop's cache-control policy before storing, and users should upgrade to one of those versions or later. As a workaround, compose the cache interceptor before the redirect interceptor, use per-origin dispatchers and cache stores, or disable shared caching on redirect-capable requests.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-109829?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.0.0 | 7.30.1 |
| `undici` | npm | From 7.0.0 | 7.30.1 |
| `undici` | npm | From 8.0.0 | 8.12.2 |
| `undici` | npm | From 8.0.0 | 8.12.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-109829?

Upgrade undici to a fixed version for your release line: 7.30.1 or 8.12.2.

## Is CVE-2026-109829 being exploited?

There is no known exploitation of CVE-2026-109829 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-109829 and fix it if it is affected.

What it is: CVE-2026-109829 is a high-severity vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-109829 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.0.0; fixed in 7.30.1
- undici (npm): affected from 7.0.0; fixed in 7.30.1
- undici (npm): affected from 8.0.0; fixed in 8.12.2
- undici (npm): affected from 8.0.0; fixed in 8.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-109829/ (Markdown: https://insights.sbomify.com/CVE-2026-109829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-109829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-109829
- OSV: https://osv.dev/vulnerability/CVE-2026-109829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-109829/
Summaries are generated and may contain mistakes; the official description above is the record.
