CVE-2026-109841 undici vulnerable to Subresource Integrity bypass via non-lowercase algorithm tokens
Attackers can bypass Subresource Integrity checks in undici by using non-lowercase algorithm tokens, allowing delivery of unverified response bodies to applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-109841?
CVE-2026-109841 is a medium-severity vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici is an HTTP client library for Node.js. In versions 7.15.0 through 7.30.0 and 8.0.0 through 8.12.1, its fetch() implementation verifies Subresource Integrity metadata by matching the algorithm token against a lowercase-only set, even though the SRI specification defines the token by its ASCII-lowercase form, so a valid but non-lowercase token such as an uppercase or mixed-case SHA256 is treated as unknown and skipped. When no recognized algorithm remains, undici treats the integrity list as empty and accepts the response, so a server returning a body that does not match the pinned digest passes the check. An attacker who controls only the response body can therefore deliver attacker-controlled bytes to an application that pinned a valid uppercase or mixed-case SRI token, with no integrity error, affecting response integrity only. The issue is fixed in undici 7.30.1 and 8.12.2, which normalize the algorithm token to ASCII lowercase before validation, and users should upgrade to one of those versions or later. As a workaround, use lowercase algorithm tokens such as sha256, sha384, or sha512 in integrity metadata.
Weakness: CWE-178
Which versions are affected by CVE-2026-109841?
4 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 7.15.0 | 7.30.1 |
undici npm | From 7.15.0 | 7.30.1 |
undici npm | From 8.0.0 | 8.12.2 |
undici npm | From 8.0.0 | 8.12.2 |
Products include Nodejs Undici.
How do I fix CVE-2026-109841?
Upgrade undici to a fixed version for your release line: 7.30.1 or 8.12.2.
Is CVE-2026-109841 being exploited?
There is no known exploitation of CVE-2026-109841 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as DEBIAN-CVE-2026-109841, ECHO-17e7-9db7-20d3, GHSA-f72v-6w45-q472, UBUNTU-CVE-2026-109841.