# CVE-2026-109841: undici vulnerable to Subresource Integrity bypass via non-lowercase algorithm tokens

> Attackers can bypass Subresource Integrity checks in undici by using non-lowercase algorithm tokens, allowing delivery of unverified response bodies to applications.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-109841, ECHO-17e7-9db7-20d3, GHSA-f72v-6w45-q472, UBUNTU-CVE-2026-109841

## What is CVE-2026-109841?

CVE-2026-109841 is a medium-severity vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici is an HTTP client library for Node.js. In versions 7.15.0 through 7.30.0 and 8.0.0 through 8.12.1, its fetch() implementation verifies Subresource Integrity metadata by matching the algorithm token against a lowercase-only set, even though the SRI specification defines the token by its ASCII-lowercase form, so a valid but non-lowercase token such as an uppercase or mixed-case SHA256 is treated as unknown and skipped. When no recognized algorithm remains, undici treats the integrity list as empty and accepts the response, so a server returning a body that does not match the pinned digest passes the check. An attacker who controls only the response body can therefore deliver attacker-controlled bytes to an application that pinned a valid uppercase or mixed-case SRI token, with no integrity error, affecting response integrity only. The issue is fixed in undici 7.30.1 and 8.12.2, which normalize the algorithm token to ASCII lowercase before validation, and users should upgrade to one of those versions or later. As a workaround, use lowercase algorithm tokens such as sha256, sha384, or sha512 in integrity metadata.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-109841?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.15.0 | 7.30.1 |
| `undici` | npm | From 7.15.0 | 7.30.1 |
| `undici` | npm | From 8.0.0 | 8.12.2 |
| `undici` | npm | From 8.0.0 | 8.12.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-109841?

Upgrade undici to a fixed version for your release line: 7.30.1 or 8.12.2.

## Is CVE-2026-109841 being exploited?

There is no known exploitation of CVE-2026-109841 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-109841 and fix it if it is affected.

What it is: CVE-2026-109841 is a medium-severity vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-109841 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.15.0; fixed in 7.30.1
- undici (npm): affected from 7.15.0; fixed in 7.30.1
- undici (npm): affected from 8.0.0; fixed in 8.12.2
- undici (npm): affected from 8.0.0; fixed in 8.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-109841/ (Markdown: https://insights.sbomify.com/CVE-2026-109841/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-109841
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-109841
- OSV: https://osv.dev/vulnerability/CVE-2026-109841

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-109841/
Summaries are generated and may contain mistakes; the official description above is the record.
