CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
A malicious server can crash Node.js clients using undici's WebSocket over HTTP/2 by triggering an unhandled error on connection destruction.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-109855?
CVE-2026-109855 is a high-severity denial of service vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici is an HTTP client library for Node.js. In versions 8.11.0 and 8.11.1, its experimental WebSocket client, which is enabled by default when HTTP/2 is allowed, mishandles a failed WebSocket handshake over HTTP/2: the request is already marked completed, so the abort becomes a no-op and the underlying HTTP/2 stream is left open with no error listener. When a malicious server then destroys the connection, the orphaned stream emits an unhandled error and the Node.js process exits. A remote, unauthenticated server can therefore crash any client that opens a WebSocket to it over HTTP/2, resulting in a denial of service. The issue is fixed in undici 8.11.2, and users should upgrade to 8.11.2 or later. As a workaround, set allowH2 to false to disable HTTP/2 for WebSocket connections, or avoid opening WebSocket connections to untrusted servers.
Which versions are affected by CVE-2026-109855?
2 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 8.11.0 | 8.11.2 |
undici npm | From 8.11.0 | 8.11.2 |
Linux distribution packages (8)
nodejs26 Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
nodejs26-bin Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
nodejs26-devel Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
nodejs26-docs Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
nodejs26-full-i18n Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
nodejs26-libs Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
nodejs26-npm Red Hat:hummingbird:1 | All versions | 0:11.20.0-1.26.11.1.0.3.hum1 |
nodejs26-npm-bin Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
Products include Nodejs Undici.
How do I fix CVE-2026-109855?
Upgrade undici to 8.11.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-109855 being exploited?
There is no known exploitation of CVE-2026-109855 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
- CVE-2026-6734 undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse
Sources
Also known as DEBIAN-CVE-2026-109855, ECHO-c178-9f2b-7f95, GHSA-qq8j-7v2v-3rwp, RHSA-2026:83198, ROOT-APP-NPM-CVE-2026-109855, UBUNTU-CVE-2026-109855.