# CVE-2026-109855: undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake

> A malicious server can crash Node.js clients using undici's WebSocket over HTTP/2 by triggering an unhandled error on connection destruction.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-109855, ECHO-c178-9f2b-7f95, GHSA-qq8j-7v2v-3rwp, RHSA-2026:83198, ROOT-APP-NPM-CVE-2026-109855, UBUNTU-CVE-2026-109855

## What is CVE-2026-109855?

CVE-2026-109855 is a high-severity denial of service vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici is an HTTP client library for Node.js. In versions 8.11.0 and 8.11.1, its experimental WebSocket client, which is enabled by default when HTTP/2 is allowed, mishandles a failed WebSocket handshake over HTTP/2: the request is already marked completed, so the abort becomes a no-op and the underlying HTTP/2 stream is left open with no error listener. When a malicious server then destroys the connection, the orphaned stream emits an unhandled error and the Node.js process exits. A remote, unauthenticated server can therefore crash any client that opens a WebSocket to it over HTTP/2, resulting in a denial of service. The issue is fixed in undici 8.11.2, and users should upgrade to 8.11.2 or later. As a workaround, set allowH2 to false to disable HTTP/2 for WebSocket connections, or avoid opening WebSocket connections to untrusted servers.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-109855?

2 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 8.11.0 | 8.11.2 |
| `undici` | npm | From 8.11.0 | 8.11.2 |
| `nodejs26` | Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
| `nodejs26-bin` | Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
| `nodejs26-devel` | Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
| `nodejs26-docs` | Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
| `nodejs26-full-i18n` | Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
| `nodejs26-libs` | Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |
| `nodejs26-npm` | Red Hat:hummingbird:1 | All versions | 0:11.20.0-1.26.11.1.0.3.hum1 |
| `nodejs26-npm-bin` | Red Hat:hummingbird:1 | All versions | 0:26.11.1-0.3.hum1 |

Products: Nodejs Undici.

## How do I fix CVE-2026-109855?

Upgrade undici to 8.11.2 or later.

## Is CVE-2026-109855 being exploited?

There is no known exploitation of CVE-2026-109855 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)
- [CVE-2026-6734](https://insights.sbomify.com/CVE-2026-6734/): undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-109855 and fix it if it is affected.

What it is: CVE-2026-109855 is a high-severity denial of service vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-109855 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 8.11.0; fixed in 8.11.2
- undici (npm): affected from 8.11.0; fixed in 8.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-109855/ (Markdown: https://insights.sbomify.com/CVE-2026-109855/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-109855
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-109855
- OSV: https://osv.dev/vulnerability/CVE-2026-109855

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-109855/
Summaries are generated and may contain mistakes; the official description above is the record.
