CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
A remote server can crash the Node.js process by sending excessive content-encodings, causing a denial of service in the undici library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-109869?
CVE-2026-109869 is a high-severity denial of service vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici is an HTTP client library for Node.js. In versions 6.23.0 through 6.29.0, 7.18.0 through 7.30.0, and 8.0.0 through 8.12.1, its fetch() implementation crashes the Node.js process when a malicious server returns a response with more than five content codings and closes the connection before sending the body. undici rejects such responses because of a content-encoding limit, but it created the internal response stream before that check and returned without attaching an error listener or aborting the request, so the early close surfaces a content-length mismatch on the orphaned stream, which Node.js treats as an unhandled error and terminates the process. A remote, unauthenticated server can trigger this with a single response, even when the application correctly catches the fetch() rejection, resulting in a denial of service. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. There is no workaround.
Which versions are affected by CVE-2026-109869?
6 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 6.23.0 | 6.29.1 |
undici npm | From 6.23.0 | 6.29.1 |
undici npm | From 7.18.0 | 7.30.1 |
undici npm | From 7.18.0 | 7.30.1 |
undici npm | From 8.0.0 | 8.12.2 |
undici npm | From 8.0.0 | 8.12.2 |
Products include Nodejs Undici.
How do I fix CVE-2026-109869?
Upgrade undici to a fixed version for your release line: 6.29.1, 7.30.1 or 8.12.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-109869 being exploited?
There is no known exploitation of CVE-2026-109869 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
- CVE-2026-6734 undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse
Sources
Also known as CLEANSTART-2026-LB99880, DEBIAN-CVE-2026-109869, ECHO-51e2-a3b1-2355, GHSA-xjj6-f33q-929c, ROOT-APP-NPM-CVE-2026-109869, UBUNTU-CVE-2026-109869.