{"answers":{"affected":"6 open source packages ship an affected version, including undici. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-109869 in the wild and no public exploit code.","fix":"Upgrade undici to a fixed version for your release line: 6.29.1, 7.30.1 or 8.12.2.","what":"CVE-2026-109869 is a high-severity denial of service vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-109869 and fix it if it is affected.\n\nWhat it is: CVE-2026-109869 is a high-severity denial of service vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-109869 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- undici (npm): affected from 6.23.0; fixed in 6.29.1\n- undici (npm): affected from 6.23.0; fixed in 6.29.1\n- undici (npm): affected from 7.18.0; fixed in 7.30.1\n- undici (npm): affected from 7.18.0; fixed in 7.30.1\n- undici (npm): affected from 8.0.0; fixed in 8.12.2\n- undici (npm): affected from 8.0.0; fixed in 8.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-109869/ (Markdown: https://insights.sbomify.com/CVE-2026-109869/index.md)","id":"CVE-2026-109869","markdown":"https://insights.sbomify.com/CVE-2026-109869/index.md","name":"CVE-2026-109869","record":{"aliases":["CLEANSTART-2026-LB99880","DEBIAN-CVE-2026-109869","ECHO-51e2-a3b1-2355","GHSA-xjj6-f33q-929c","ROOT-APP-NPM-CVE-2026-109869","UBUNTU-CVE-2026-109869"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP client","requires_auth":"none","summary":"A remote server can crash the Node.js process by sending excessive content-encodings, causing a denial of service in the undici library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"undici","vendor":"nodejs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-459","name":"Incomplete Cleanup"},{"id":"CWE-248","name":"Uncaught Exception"}],"description":"undici is an HTTP client library for Node.js. In versions 6.23.0 through 6.29.0, 7.18.0 through 7.30.0, and 8.0.0 through 8.12.1, its fetch() implementation crashes the Node.js process when a malicious server returns a response with more than five content codings and closes the connection before sending the body. undici rejects such responses because of a content-encoding limit, but it created the internal response stream before that check and returned without attaching an error listener or aborting the request, so the early close surfaces a content-length mismatch on the orphaned stream, which Node.js treats as an unhandled error and terminates the process. A remote, unauthenticated server can trigger this with a single response, even when the application correctly catches the fetch() rejection, resulting in a denial of service. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. There is no workaround.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"undici vulnerable to Denial of Service via unhandled error on excessive content-encodings","id":"CVE-2026-109869","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"nodejs:undici","products":["nodejs:undici"],"type":"denial_of_service","year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"WordPress Premium Addons for Elementor plugin \u003c= 4.11.110 - Broken Access Control vulnerability","id":"CVE-2026-109890"},"packages":[{"ecosystem":"npm","fixed":["6.29.1"],"introduced":["6.23.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-xjj6-f33q-929c"},{"ecosystem":"npm","fixed":["6.29.1"],"introduced":["6.23.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-xjj6-f33q-929c"},{"ecosystem":"npm","fixed":["7.30.1"],"introduced":["7.18.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-xjj6-f33q-929c"},{"ecosystem":"npm","fixed":["7.30.1"],"introduced":["7.18.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-xjj6-f33q-929c"},{"ecosystem":"npm","fixed":["8.12.2"],"introduced":["8.0.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-xjj6-f33q-929c"},{"ecosystem":"npm","fixed":["8.12.2"],"introduced":["8.0.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-xjj6-f33q-929c"}],"prev":{"headline":"undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake","id":"CVE-2026-109855"},"products":["undici"],"published":"2026-10-15","related":[{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake","id":"CVE-2026-109855","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation","id":"CVE-2026-87018","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via unrequested WebSocket subprotocol","id":"CVE-2026-19534","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to denial of service via fragment count bypass","id":"CVE-2026-12151","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":7.5,"headline":"undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse","id":"CVE-2026-6734","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to denial of service via cumulative fragment bypass","id":"CVE-2026-9675","kev_date_added":null,"published":"2026-06-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-16","vendors":["undici"]},"summary":"A remote server can crash the Node.js process by sending excessive content-encodings, causing a denial of service in the undici library.","url":"https://insights.sbomify.com/CVE-2026-109869/"}