CVE-2026-109924 undici vulnerable to Denial of Service via unbounded memory in the EventSource parser
A malicious Server-Sent Events peer can exhaust memory in undici, causing a denial of service in applications maintaining EventSource connections.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-109924?
CVE-2026-109924 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici is an HTTP client library for Node.js. In versions 6.5.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state that the byte-based maxEventSize and maxResponseSize limits do not bound, and because maxResponseSize is enforced on the compressed body before decompression, a small compressed response can expand into enough retained memory to terminate the process. An application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response, and availability is the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which bound the retained parser state independently of the byte limits, and users should upgrade to one of those versions or later. There is no workaround.
Weakness: CWE-770
Which versions are affected by CVE-2026-109924?
6 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 6.5.0 | 6.29.1 |
undici npm | From 6.5.0 | 6.29.1 |
undici npm | From 7.0.0 | 7.30.1 |
undici npm | From 7.0.0 | 7.30.1 |
undici npm | From 8.0.0 | 8.12.2 |
undici npm | From 8.0.0 | 8.12.2 |
Products include Nodejs Undici.
How do I fix CVE-2026-109924?
Upgrade undici to a fixed version for your release line: 6.29.1, 7.30.1 or 8.12.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-109924 being exploited?
There is no known exploitation of CVE-2026-109924 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as CLEANSTART-2026-XE59858, CLSA-2026-1793111891, CLSA-2026-1793112018, CLSA-2026-1793125814, CLSA-2026-1793125928, DEBIAN-CVE-2026-109924 and 3 more.