CVE-2026-109932 undici WebSocket client vulnerable to Denial of Service via unbounded automatic PONG buffering
A malicious WebSocket server can exhaust memory in the undici library by flooding PING frames, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-109932?
CVE-2026-109932 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici is an HTTP client library for Node.js. In versions 5.15.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its WebSocket client, including the bundled WebSocket exposed by Node.js, can be driven to exhaust process memory by a malicious or compromised WebSocket server. For every PING frame received, the client automatically writes a PONG response and ignores the backpressure signal from the socket write, so a server that streams small PING frames while never reading the client's PONGs makes the outbound write queue and heap grow without bound until the Node.js process runs out of memory and terminates. The attack is remote and unauthenticated, needs only a normal WebSocket connection, and is asymmetric, since small inbound PINGs produce a much larger retained outbound queue, with availability the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which pause WebSocket frame parsing when the automatic PONG response hits socket backpressure and resume on drain, bounding the outbound queue, and users should upgrade to one of those versions or later. There is no workaround.
Which versions are affected by CVE-2026-109932?
6 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 5.15.0 | 6.29.1 |
undici npm | From 5.15.0 | 6.29.1 |
undici npm | From 7.0.0 | 7.30.1 |
undici npm | From 7.0.0 | 7.30.1 |
undici npm | From 8.0.0 | 8.12.2 |
undici npm | From 8.0.0 | 8.12.2 |
Products include Nodejs Undici.
How do I fix CVE-2026-109932?
Upgrade undici to a fixed version for your release line: 6.29.1, 7.30.1 or 8.12.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-109932 being exploited?
There is no known exploitation of CVE-2026-109932 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as CLEANSTART-2026-ME95342, DEBIAN-CVE-2026-109932, ECHO-eedf-2067-3e77, GHSA-9fm3-97px-rjf6, UBUNTU-CVE-2026-109932.