CVE-2026-109954 Parse Server 9.0.0 before 9.10.2-alpha.5 Transactional Batch Request Write Interference

High 8.3 Published Updated

Concurrent transactional batch requests interfere with other clients' database writes, causing rollbacks or indefinite open transactions in Parse Server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-109954?

CVE-2026-109954 is a high-severity vulnerability in parse-community parse-server, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Parse Server 5.4.0 before 8.6.96 and 9.0.0 before 9.10.2-alpha.5 shares transactional batch state across concurrent requests, letting any client's transactional batch request interfere with other clients' database writes. On PostgreSQL or MongoDB replica sets and sharded clusters, other clients' acknowledged writes are rolled back if the batch fails, and PostgreSQL transactions can remain open indefinitely, causing subsequent writes to fail.

Weakness: CWE-362

Which versions are affected by CVE-2026-109954?

1 open source package ship an affected version, including parse.

PackageAffectedFixed in
parse BitnamiFrom 5.4.08.6.96, 9.10.2

How do I fix CVE-2026-109954?

Upgrade parse to a fixed version for your release line: 8.6.96 or 9.10.2.

Is CVE-2026-109954 being exploited?

There is no known exploitation of CVE-2026-109954 in the wild and no public exploit code.

Sources

Also known as BIT-parse-2026-109954, GHSA-jhh9-hrgh-c9gv, GHSA-jq9m-gc39-vm65.

Is CVE-2026-109954 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free