# CVE-2026-109954: Parse Server 9.0.0 before 9.10.2-alpha.5 Transactional Batch Request Write Interference

> Concurrent transactional batch requests interfere with other clients' database writes, causing rollbacks or indefinite open transactions in Parse Server.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** BIT-parse-2026-109954, GHSA-jhh9-hrgh-c9gv, GHSA-jq9m-gc39-vm65

## What is CVE-2026-109954?

CVE-2026-109954 is a high-severity vulnerability in parse-community parse-server, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server 5.4.0 before 8.6.96 and 9.0.0 before 9.10.2-alpha.5 shares transactional batch state across concurrent requests, letting any client's transactional batch request interfere with other clients' database writes. On PostgreSQL or MongoDB replica sets and sharded clusters, other clients' acknowledged writes are rolled back if the batch fails, and PostgreSQL transactions can remain open indefinitely, causing subsequent writes to fail.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-109954?

1 open source package ship an affected version, including parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse` | Bitnami | From 5.4.0 | 8.6.96, 9.10.2 |

## How do I fix CVE-2026-109954?

Upgrade parse to a fixed version for your release line: 8.6.96 or 9.10.2.

## Is CVE-2026-109954 being exploited?

There is no known exploitation of CVE-2026-109954 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-109954 and fix it if it is affected.

What it is: CVE-2026-109954 is a high-severity vulnerability in parse-community parse-server, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-109954 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse (Bitnami): affected from 5.4.0; fixed in 8.6.96, 9.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-109954/ (Markdown: https://insights.sbomify.com/CVE-2026-109954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-109954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-109954
- OSV: https://osv.dev/vulnerability/CVE-2026-109954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-109954/
Summaries are generated and may contain mistakes; the official description above is the record.
