# CVE-2026-109956: NLTK through 3.10.3 Path Traversal via WekaClassifier Model Path

> Attackers can bypass path restrictions in NLTK's WekaClassifier to read or write files outside allowed directories via unvalidated model paths.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-109956, ECHO-d53c-5278-1d0e, GHSA-9fgx-q9j8-3j83, GHSA-j456-xh4h-cpf2, UBUNTU-CVE-2026-109956

## What is CVE-2026-109956?

CVE-2026-109956 is a high-severity path traversal vulnerability in nltk, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NLTK through 3.10.3 contains a path traversal vulnerability in WekaClassifier that allows attackers to bypass nltk.pathsec containment by supplying unvalidated model paths. Attackers controlling the model_filename or model argument can make the weka JVM write files via -d or probe files via -l outside allowed data roots.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-109956?

2 open source packages ship an affected version, including nltk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.10.4 |
| `nltk` | PyPI | All versions | 3.10.4 |

## How do I fix CVE-2026-109956?

Upgrade nltk to 3.10.4 or later.

## Is CVE-2026-109956 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-109956 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-109956 and fix it if it is affected.

What it is: CVE-2026-109956 is a high-severity path traversal vulnerability in nltk, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-109956 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.10.4
- nltk (PyPI): affected all versions; fixed in 3.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-109956/ (Markdown: https://insights.sbomify.com/CVE-2026-109956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-109956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-109956
- OSV: https://osv.dev/vulnerability/CVE-2026-109956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-109956/
Summaries are generated and may contain mistakes; the official description above is the record.
