{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-110008 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-110008 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-110008 is a medium-severity vulnerability in @fastify/oauth2, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-110008 and fix it if it is affected.\n\nWhat it is: CVE-2026-110008 is a medium-severity vulnerability in @fastify/oauth2, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-110008 in the wild and no public exploit code.\n\nAffected product: @fastify/oauth2. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-110008/ (Markdown: https://insights.sbomify.com/CVE-2026-110008/index.md)","id":"CVE-2026-110008","markdown":"https://insights.sbomify.com/CVE-2026-110008/index.md","name":"CVE-2026-110008","record":{"aliases":["GHSA-7fcr-mwg4-pw9q"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Fastify OAuth2 library","requires_auth":"none","summary":"Attackers can perform login CSRF by reusing OAuth state cookies, allowing them to sign victims into attacker-controlled accounts.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-459","name":"Incomplete Cleanup"},{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"},{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"@fastify/oauth2 is a Fastify wrapper for OAuth2 login flows. In versions 7.2.0 through 8.3.1, the state and code-verifier cookies are set without a Path attribute at a login route with two or more path segments, while the clearing step at the OAuth callback writes them with a root path, so the original cookies survive the callback and the documented single-use guarantee for the state value does not hold. A state value an attacker learns stays valid for the rest of the browser session, letting the attacker drive their own authorization flow in the victim's browser and sign the victim in to the attacker's account (login CSRF). The issue is fixed in @fastify/oauth2 8.3.2, and users should upgrade to 8.3.2 or later. As a workaround, set an explicit cookie path so the set and the clear name the same cookie.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"@fastify/oauth2 vulnerable to Login CSRF via OAuth state cookie not cleared after callback","id":"CVE-2026-110008","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"MB Custom Post Types \u0026 Custom Taxonomies 2.0.2 - 2.12.2 - Unauthenticated Settings Reset via 'mbcpt-force' Parameter","id":"CVE-2026-110010"},"packages":[],"prev":{"headline":"Moghtech Komodo contains an OS command injection vulnerability","id":"CVE-2026-110005"},"products":["@fastify/oauth2"],"published":"2026-10-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-19","vendors":["@fastify/oauth2"]},"summary":"Attackers can perform login CSRF by reusing OAuth state cookies, allowing them to sign victims into attacker-controlled accounts.","url":"https://insights.sbomify.com/CVE-2026-110008/"}