# CVE-2026-110008: @fastify/oauth2 vulnerable to Login CSRF via OAuth state cookie not cleared after callback

> Attackers can perform login CSRF by reusing OAuth state cookies, allowing them to sign victims into attacker-controlled accounts.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-7fcr-mwg4-pw9q

## What is CVE-2026-110008?

CVE-2026-110008 is a medium-severity vulnerability in @fastify/oauth2, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

@fastify/oauth2 is a Fastify wrapper for OAuth2 login flows. In versions 7.2.0 through 8.3.1, the state and code-verifier cookies are set without a Path attribute at a login route with two or more path segments, while the clearing step at the OAuth callback writes them with a root path, so the original cookies survive the callback and the documented single-use guarantee for the state value does not hold. A state value an attacker learns stays valid for the rest of the browser session, letting the attacker drive their own authorization flow in the victim's browser and sign the victim in to the attacker's account (login CSRF). The issue is fixed in @fastify/oauth2 8.3.2, and users should upgrade to 8.3.2 or later. As a workaround, set an explicit cookie path so the set and the clear name the same cookie.

Weakness: CWE-459 (Incomplete Cleanup), CWE-613 (DEPRECATED: Insufficient Session Expiration), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-110008?


## How do I fix CVE-2026-110008?

No fix has been published for CVE-2026-110008 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-110008 being exploited?

There is no known exploitation of CVE-2026-110008 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110008 and fix it if it is affected.

What it is: CVE-2026-110008 is a medium-severity vulnerability in @fastify/oauth2, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-110008 in the wild and no public exploit code.

Affected product: @fastify/oauth2. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110008/ (Markdown: https://insights.sbomify.com/CVE-2026-110008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110008
- OSV: https://osv.dev/vulnerability/CVE-2026-110008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110008/
Summaries are generated and may contain mistakes; the official description above is the record.
