# CVE-2026-110024: @fastify/jwt vulnerable to missing token expiration when per-call options drop global defaults

> Attackers can use never-expiring JWTs because per-call options override global expiration settings, bypassing token validity checks in @fastify/jwt.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-f5gh-84pj-v2pg

## What is CVE-2026-110024?

CVE-2026-110024 is a medium-severity vulnerability in @fastify/jwt, published on 18 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

@fastify/jwt is a JWT utility plugin for Fastify. In versions prior to 10.2.5, the top-level sign and verify methods replace the globally configured defaults with the per-call options instead of merging them, so passing any per-call option silently drops every global default that the call does not restate, including temporal protections such as token expiration and maximum accepted token age. A token signed this way carries no expiration claim and never expires, and verification stops enforcing a configured maximum age, so stale or never-expiring tokens are accepted. The route-level decorators for signing and verifying already merge options and are not affected. The issue is fixed in @fastify/jwt 10.2.5, and users should upgrade to 10.2.5 or later.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-110024?


## How do I fix CVE-2026-110024?

No fix has been published for CVE-2026-110024 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-110024 being exploited?

There is no known exploitation of CVE-2026-110024 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110024 and fix it if it is affected.

What it is: CVE-2026-110024 is a medium-severity vulnerability in @fastify/jwt, published on 18 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-110024 in the wild and no public exploit code.

Affected product: @fastify/jwt. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110024/ (Markdown: https://insights.sbomify.com/CVE-2026-110024/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110024
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110024
- OSV: https://osv.dev/vulnerability/CVE-2026-110024

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110024/
Summaries are generated and may contain mistakes; the official description above is the record.
