CVE-2026-110095 fast-uri vulnerable to improper path equivalence in relative reference normalization

Low 3.7 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-110095?

CVE-2026-110095 is a low-severity vulnerability in fast-uri, published on 20 Oct 2026.

Official description

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, the normalize() and serialize() functions apply RFC 3986 dot-segment removal to the path of a relative-path reference, even though that algorithm is defined only for the merged target path during resolution, so a leading parent-directory segment can be dropped and a document-relative reference can become root-relative. An application that normalizes an attacker-supplied or user-supplied relative reference and then resolves it, or uses it as a cache, deduplication, or authorization key, can have the reference escape its intended directory and point at a different resource. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, resolve a relative reference against its absolute base first and normalize the absolute result instead of normalizing the reference beforehand.

Weakness: CWE-41

Which versions are affected by CVE-2026-110095?

6 open source packages ship an affected version, including fast-uri.

PackageAffectedFixed in
fast-uri npmAll versions2.4.8
fast-uri npmAll versions2.4.8
fast-uri npmFrom 3.0.03.1.9
fast-uri npmFrom 3.0.03.1.9
fast-uri npmFrom 4.0.04.2.3
fast-uri npmFrom 4.0.04.2.3

How do I fix CVE-2026-110095?

Upgrade fast-uri to a fixed version for your release line: 2.4.8, 3.1.9 or 4.2.3.

Is CVE-2026-110095 being exploited?

There is no known exploitation of CVE-2026-110095 in the wild and no public exploit code.

Sources

Also known as CLSA-2026-1793097189, DEBIAN-CVE-2026-110095, ECHO-abc0-48c5-8ab4, GHSA-xhq7-xmqj-769h, MINI-5cg8-33fj-5h8w, MINI-5r6x-2p3j-j4gw and 7 more.

Is CVE-2026-110095 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free