{"answers":{"affected":"6 open source packages ship an affected version, including fast-uri.","exploited":"There is no known exploitation of CVE-2026-110095 in the wild and no public exploit code.","fix":"Upgrade fast-uri to a fixed version for your release line: 2.4.8, 3.1.9 or 4.2.3.","what":"CVE-2026-110095 is a low-severity vulnerability in fast-uri, published on 20 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-110095 and fix it if it is affected.\n\nWhat it is: CVE-2026-110095 is a low-severity vulnerability in fast-uri, published on 20 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-110095 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fast-uri (npm): affected all versions; fixed in 2.4.8\n- fast-uri (npm): affected all versions; fixed in 2.4.8\n- fast-uri (npm): affected from 3.0.0; fixed in 3.1.9\n- fast-uri (npm): affected from 3.0.0; fixed in 3.1.9\n- fast-uri (npm): affected from 4.0.0; fixed in 4.2.3\n- fast-uri (npm): affected from 4.0.0; fixed in 4.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-110095/ (Markdown: https://insights.sbomify.com/CVE-2026-110095/index.md)","id":"CVE-2026-110095","markdown":"https://insights.sbomify.com/CVE-2026-110095/index.md","name":"CVE-2026-110095","record":{"aliases":["CLSA-2026-1793097189","DEBIAN-CVE-2026-110095","ECHO-abc0-48c5-8ab4","GHSA-xhq7-xmqj-769h","MINI-5cg8-33fj-5h8w","MINI-5r6x-2p3j-j4gw","MINI-8ph7-w7hr-fgwh","MINI-9r35-p649-433f","MINI-c727-c3vp-r9rp","MINI-gcj3-qxr8-923f","MINI-w996-xhv7-x372","MINI-wg89-phmw-8hvw","UBUNTU-CVE-2026-110095"],"analysis":null,"analysis_generated_by":null,"assigner":"openjs","cpe":[],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-41","name":"Improper Resolution of Path Equivalence"}],"description":"fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, the normalize() and serialize() functions apply RFC 3986 dot-segment removal to the path of a relative-path reference, even though that algorithm is defined only for the merged target path during resolution, so a leading parent-directory segment can be dropped and a document-relative reference can become root-relative. An application that normalizes an attacker-supplied or user-supplied relative reference and then resolves it, or uses it as a cache, deduplication, or authorization key, can have the reference escape its intended directory and point at a different resource. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, resolve a relative reference against its absolute base first and normalize the absolute result instead of normalizing the reference beforehand.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"fast-uri vulnerable to improper path equivalence in relative reference normalization","id":"CVE-2026-110095","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"Ikaros 1.2.0 through 1.2.5 TOTP Authentication Bypass via Temp Token","id":"CVE-2026-110097"},"packages":[{"ecosystem":"npm","fixed":["2.4.8"],"introduced":["0"],"last_affected":[],"package":"fast-uri","purl":null,"source":"GHSA-xhq7-xmqj-769h"},{"ecosystem":"npm","fixed":["2.4.8"],"introduced":["0"],"last_affected":[],"package":"fast-uri","purl":"pkg:npm/fast-uri","source":"GHSA-xhq7-xmqj-769h"},{"ecosystem":"npm","fixed":["3.1.9"],"introduced":["3.0.0"],"last_affected":[],"package":"fast-uri","purl":null,"source":"GHSA-xhq7-xmqj-769h"},{"ecosystem":"npm","fixed":["3.1.9"],"introduced":["3.0.0"],"last_affected":[],"package":"fast-uri","purl":"pkg:npm/fast-uri","source":"GHSA-xhq7-xmqj-769h"},{"ecosystem":"npm","fixed":["4.2.3"],"introduced":["4.0.0"],"last_affected":[],"package":"fast-uri","purl":null,"source":"GHSA-xhq7-xmqj-769h"},{"ecosystem":"npm","fixed":["4.2.3"],"introduced":["4.0.0"],"last_affected":[],"package":"fast-uri","purl":"pkg:npm/fast-uri","source":"GHSA-xhq7-xmqj-769h"}],"prev":{"headline":"Adobe Experience Manager | XML Injection (aka Blind XPath Injection) (CWE-91)","id":"CVE-2026-110084"},"products":["fast-uri"],"published":"2026-10-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-20","vendors":["fast-uri"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-110095/"}