# CVE-2026-110095: fast-uri vulnerable to improper path equivalence in relative reference normalization


- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** CLSA-2026-1793097189, DEBIAN-CVE-2026-110095, ECHO-abc0-48c5-8ab4, GHSA-xhq7-xmqj-769h, MINI-5cg8-33fj-5h8w, MINI-5r6x-2p3j-j4gw, MINI-8ph7-w7hr-fgwh, MINI-9r35-p649-433f, MINI-c727-c3vp-r9rp, MINI-gcj3-qxr8-923f, MINI-w996-xhv7-x372, MINI-wg89-phmw-8hvw, UBUNTU-CVE-2026-110095

## What is CVE-2026-110095?

CVE-2026-110095 is a low-severity vulnerability in fast-uri, published on 20 Oct 2026. 

### Official description

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, the normalize() and serialize() functions apply RFC 3986 dot-segment removal to the path of a relative-path reference, even though that algorithm is defined only for the merged target path during resolution, so a leading parent-directory segment can be dropped and a document-relative reference can become root-relative. An application that normalizes an attacker-supplied or user-supplied relative reference and then resolves it, or uses it as a cache, deduplication, or authorization key, can have the reference escape its intended directory and point at a different resource. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, resolve a relative reference against its absolute base first and normalize the absolute result instead of normalizing the reference beforehand.

Weakness: CWE-41 (Improper Resolution of Path Equivalence)

## Which versions are affected by CVE-2026-110095?

6 open source packages ship an affected version, including fast-uri.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-uri` | npm | All versions | 2.4.8 |
| `fast-uri` | npm | All versions | 2.4.8 |
| `fast-uri` | npm | From 3.0.0 | 3.1.9 |
| `fast-uri` | npm | From 3.0.0 | 3.1.9 |
| `fast-uri` | npm | From 4.0.0 | 4.2.3 |
| `fast-uri` | npm | From 4.0.0 | 4.2.3 |

## How do I fix CVE-2026-110095?

Upgrade fast-uri to a fixed version for your release line: 2.4.8, 3.1.9 or 4.2.3.

## Is CVE-2026-110095 being exploited?

There is no known exploitation of CVE-2026-110095 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110095 and fix it if it is affected.

What it is: CVE-2026-110095 is a low-severity vulnerability in fast-uri, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-110095 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-uri (npm): affected all versions; fixed in 2.4.8
- fast-uri (npm): affected all versions; fixed in 2.4.8
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.9
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.9
- fast-uri (npm): affected from 4.0.0; fixed in 4.2.3
- fast-uri (npm): affected from 4.0.0; fixed in 4.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110095/ (Markdown: https://insights.sbomify.com/CVE-2026-110095/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110095
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110095
- OSV: https://osv.dev/vulnerability/CVE-2026-110095

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110095/
Summaries are generated and may contain mistakes; the official description above is the record.
