CVE-2026-1101 Improper Validation of Specified Quantity in Input in GitLab

Medium 6.5 Published Updated

An authenticated user can cause denial of service to the GitLab instance via improper input validation in GraphQL queries.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-1101?

CVE-2026-1101 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 8 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.2 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that could have allowed an authenticated user to cause denial of service to the GitLab instance due to improper input validation in GraphQL queries.

Weakness: CWE-1284

Which versions are affected by CVE-2026-1101?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.2.018.8.9, 18.9.5, 18.10.3

Products include Gitlab Gitlab.

How do I fix CVE-2026-1101?

Upgrade gitlab to a fixed version for your release line: 18.8.9, 18.9.5 or 18.10.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-1101 being exploited?

There is no known exploitation of CVE-2026-1101 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-1101, GHSA-ffch-rw3v-4mvx, UBUNTU-CVE-2026-1101.

Is CVE-2026-1101 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free