CVE-2026-110180 fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization

Medium 4.8 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-110180?

CVE-2026-110180 is a medium-severity vulnerability in fast-uri, published on 20 Oct 2026.

Official description

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions from 2.4.2 through 2.4.7, from 3.1.3 through 3.1.8, and from 4.0.1 through 4.2.2, for HTTP-family schemes the canonicalizeHost() function passes the parsed host to the WHATWG URL parser and adopts its hostname without checking that the parser consumed the entire input as a host, so the authority can be silently rewritten: data before an at-sign is dropped and tab, carriage-return, and line-feed characters are stripped, with no error reported. An application that enforces host-based policy such as denylists, loopback filtering, redirect validation, or outbound proxy routing on one representation can then see the canonical host diverge from what it checked, allowing traffic to be steered to an unintended destination. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, reject an authority that contains more than one at-sign or any tab, carriage-return, or line-feed before calling fast-uri, or treat any non-empty parse error as fatal and compare hosts only from the same parse result.

Weakness: CWE-436, CWE-20

Which versions are affected by CVE-2026-110180?

6 open source packages ship an affected version, including fast-uri.

PackageAffectedFixed in
fast-uri npmFrom 2.4.22.4.8
fast-uri npmFrom 2.4.22.4.8
fast-uri npmFrom 3.1.33.1.9
fast-uri npmFrom 3.1.33.1.9
fast-uri npmFrom 4.0.14.2.3
fast-uri npmFrom 4.0.14.2.3

How do I fix CVE-2026-110180?

Upgrade fast-uri to a fixed version for your release line: 2.4.8, 3.1.9 or 4.2.3.

Is CVE-2026-110180 being exploited?

There is no known exploitation of CVE-2026-110180 in the wild and no public exploit code.

Sources

Also known as CLSA-2026-1792486192, CLSA-2026-1792495280, CLSA-2026-1793097055, CLSA-2026-1793097300, CLSA-2026-1793100044, CLSA-2026-1793110570 and 6 more.

Is CVE-2026-110180 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free