{"answers":{"affected":"6 open source packages ship an affected version, including fast-uri.","exploited":"There is no known exploitation of CVE-2026-110180 in the wild and no public exploit code.","fix":"Upgrade fast-uri to a fixed version for your release line: 2.4.8, 3.1.9 or 4.2.3.","what":"CVE-2026-110180 is a medium-severity vulnerability in fast-uri, published on 20 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-110180 and fix it if it is affected.\n\nWhat it is: CVE-2026-110180 is a medium-severity vulnerability in fast-uri, published on 20 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-110180 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fast-uri (npm): affected from 2.4.2; fixed in 2.4.8\n- fast-uri (npm): affected from 2.4.2; fixed in 2.4.8\n- fast-uri (npm): affected from 3.1.3; fixed in 3.1.9\n- fast-uri (npm): affected from 3.1.3; fixed in 3.1.9\n- fast-uri (npm): affected from 4.0.1; fixed in 4.2.3\n- fast-uri (npm): affected from 4.0.1; fixed in 4.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-110180/ (Markdown: https://insights.sbomify.com/CVE-2026-110180/index.md)","id":"CVE-2026-110180","markdown":"https://insights.sbomify.com/CVE-2026-110180/index.md","name":"CVE-2026-110180","record":{"aliases":["CLSA-2026-1792486192","CLSA-2026-1792495280","CLSA-2026-1793097055","CLSA-2026-1793097300","CLSA-2026-1793100044","CLSA-2026-1793110570","DEBIAN-CVE-2026-110180","ECHO-df57-d6dc-c356","GHSA-wjr9-j795-jxcr","MINI-98j9-p2gc-8qf5","MINI-q62h-x5mw-9qph","UBUNTU-CVE-2026-110180"],"analysis":null,"analysis_generated_by":null,"assigner":"openjs","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-436","name":"Interpretation Conflict"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions from 2.4.2 through 2.4.7, from 3.1.3 through 3.1.8, and from 4.0.1 through 4.2.2, for HTTP-family schemes the canonicalizeHost() function passes the parsed host to the WHATWG URL parser and adopts its hostname without checking that the parser consumed the entire input as a host, so the authority can be silently rewritten: data before an at-sign is dropped and tab, carriage-return, and line-feed characters are stripped, with no error reported. An application that enforces host-based policy such as denylists, loopback filtering, redirect validation, or outbound proxy routing on one representation can then see the canonical host diverge from what it checked, allowing traffic to be steered to an unintended destination. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, reject an authority that contains more than one at-sign or any tab, carriage-return, or line-feed before calling fast-uri, or treat any non-empty parse error as fatal and compare hosts only from the same parse result.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization","id":"CVE-2026-110180","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"PostgreSQL Anonymizer: Function declared with SQL-standard syntax leak anonymized data","id":"CVE-2026-110181"},"packages":[{"ecosystem":"npm","fixed":["2.4.8"],"introduced":["2.4.2"],"last_affected":[],"package":"fast-uri","purl":null,"source":"GHSA-wjr9-j795-jxcr"},{"ecosystem":"npm","fixed":["2.4.8"],"introduced":["2.4.2"],"last_affected":[],"package":"fast-uri","purl":"pkg:npm/fast-uri","source":"GHSA-wjr9-j795-jxcr"},{"ecosystem":"npm","fixed":["3.1.9"],"introduced":["3.1.3"],"last_affected":[],"package":"fast-uri","purl":null,"source":"GHSA-wjr9-j795-jxcr"},{"ecosystem":"npm","fixed":["3.1.9"],"introduced":["3.1.3"],"last_affected":[],"package":"fast-uri","purl":"pkg:npm/fast-uri","source":"GHSA-wjr9-j795-jxcr"},{"ecosystem":"npm","fixed":["4.2.3"],"introduced":["4.0.1"],"last_affected":[],"package":"fast-uri","purl":null,"source":"GHSA-wjr9-j795-jxcr"},{"ecosystem":"npm","fixed":["4.2.3"],"introduced":["4.0.1"],"last_affected":[],"package":"fast-uri","purl":"pkg:npm/fast-uri","source":"GHSA-wjr9-j795-jxcr"}],"prev":{"headline":"affiliate-toolkit \u003c 3.8.9 - Editor+ SQL Injection via orderby Parameter","id":"CVE-2026-110179"},"products":["fast-uri"],"published":"2026-10-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-20","vendors":["fast-uri"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-110180/"}