# CVE-2026-110180: fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization


- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** CLSA-2026-1792486192, CLSA-2026-1792495280, CLSA-2026-1793097055, CLSA-2026-1793097300, CLSA-2026-1793100044, CLSA-2026-1793110570, DEBIAN-CVE-2026-110180, ECHO-df57-d6dc-c356, GHSA-wjr9-j795-jxcr, MINI-98j9-p2gc-8qf5, MINI-q62h-x5mw-9qph, UBUNTU-CVE-2026-110180

## What is CVE-2026-110180?

CVE-2026-110180 is a medium-severity vulnerability in fast-uri, published on 20 Oct 2026. 

### Official description

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions from 2.4.2 through 2.4.7, from 3.1.3 through 3.1.8, and from 4.0.1 through 4.2.2, for HTTP-family schemes the canonicalizeHost() function passes the parsed host to the WHATWG URL parser and adopts its hostname without checking that the parser consumed the entire input as a host, so the authority can be silently rewritten: data before an at-sign is dropped and tab, carriage-return, and line-feed characters are stripped, with no error reported. An application that enforces host-based policy such as denylists, loopback filtering, redirect validation, or outbound proxy routing on one representation can then see the canonical host diverge from what it checked, allowing traffic to be steered to an unintended destination. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, reject an authority that contains more than one at-sign or any tab, carriage-return, or line-feed before calling fast-uri, or treat any non-empty parse error as fatal and compare hosts only from the same parse result.

Weakness: CWE-436 (Interpretation Conflict), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-110180?

6 open source packages ship an affected version, including fast-uri.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-uri` | npm | From 2.4.2 | 2.4.8 |
| `fast-uri` | npm | From 2.4.2 | 2.4.8 |
| `fast-uri` | npm | From 3.1.3 | 3.1.9 |
| `fast-uri` | npm | From 3.1.3 | 3.1.9 |
| `fast-uri` | npm | From 4.0.1 | 4.2.3 |
| `fast-uri` | npm | From 4.0.1 | 4.2.3 |

## How do I fix CVE-2026-110180?

Upgrade fast-uri to a fixed version for your release line: 2.4.8, 3.1.9 or 4.2.3.

## Is CVE-2026-110180 being exploited?

There is no known exploitation of CVE-2026-110180 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110180 and fix it if it is affected.

What it is: CVE-2026-110180 is a medium-severity vulnerability in fast-uri, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-110180 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-uri (npm): affected from 2.4.2; fixed in 2.4.8
- fast-uri (npm): affected from 2.4.2; fixed in 2.4.8
- fast-uri (npm): affected from 3.1.3; fixed in 3.1.9
- fast-uri (npm): affected from 3.1.3; fixed in 3.1.9
- fast-uri (npm): affected from 4.0.1; fixed in 4.2.3
- fast-uri (npm): affected from 4.0.1; fixed in 4.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110180/ (Markdown: https://insights.sbomify.com/CVE-2026-110180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110180
- OSV: https://osv.dev/vulnerability/CVE-2026-110180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110180/
Summaries are generated and may contain mistakes; the official description above is the record.
