CVE-2026-110264 Integer Overflow or Wraparound in GitLab
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-110264?
CVE-2026-110264 is a critical vulnerability in Gitlab Gitlab, published on 22 Oct 2026.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before 18.11.13, 19.0 before 19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server due to integer overflow when compiling a specially crafted regular expression.
Weakness: CWE-190
Which versions are affected by CVE-2026-110264?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 7.0.0 | 18.11.13, 19.0.10, 19.1.9, 19.2.9, 19.3.6, 19.4.3, 19.5.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2026-110264?
Upgrade gitlab to a fixed version for your release line: 18.11.13, 19.0.10, 19.1.9 or 19.2.9.
Is CVE-2026-110264 being exploited?
There is no known exploitation of CVE-2026-110264 in the wild and no public exploit code.
Public exploit code: 12 proofs of concept on GitHub.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as ALPINE-CVE-2026-110264, AZL-111071, BELL-CVE-2026-110264, BIT-gitlab-2026-110264, DEBIAN-CVE-2026-110264, GHSA-83vq-rvff-66gw.