# CVE-2026-110264: Integer Overflow or Wraparound in GitLab


- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 22 Oct 2026
- **Also known as:** ALPINE-CVE-2026-110264, AZL-111071, BELL-CVE-2026-110264, BIT-gitlab-2026-110264, DEBIAN-CVE-2026-110264, GHSA-83vq-rvff-66gw

## What is CVE-2026-110264?

CVE-2026-110264 is a critical vulnerability in Gitlab Gitlab, published on 22 Oct 2026. 

### Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before 18.11.13, 19.0 before 19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server due to integer overflow when compiling a specially crafted regular expression.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-110264?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 7.0.0 | 18.11.13, 19.0.10, 19.1.9, 19.2.9, 19.3.6, 19.4.3, 19.5.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2026-110264?

Upgrade gitlab to a fixed version for your release line: 18.11.13, 19.0.10, 19.1.9 or 19.2.9.

## Is CVE-2026-110264 being exploited?

There is no known exploitation of CVE-2026-110264 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-110264: GitLab pre-auth RCE via Onigmo integer overflow in org-ruby. Docker-based validation, admin check script, attack surface analysis. (github_poc): https://github.com/al4n4n/CVE-2026-110264
- Local detector for CVE-2026-110264 (GitLab Onigmo regex repeat-ID overflow, CVSS 10.0 unauth RCE). One-file Ruby check + real crash transcript. (github_poc): https://github.com/TahuCryptsi/gitlab-onigmo-check
- CVE-2026-110264 — GitLab Unauthenticated RCE (Onigmo regex repeat-ID overflow, CVSS 10.0). Docker-verified crash PoC on ruby 3.4.11 + measured heap analysis. Crash-level, non-weaponized. (github_poc): https://github.com/TahuCryptsi/poc-gitlab-onigmo-cve-2026-110264
- Fast, concurrent and non-intrusive exposure auditor in Go for GitLab CE/EE unauthenticated RCE (CVE-2026-110264 - CVSS 10.0) (github_poc): https://github.com/xaviware/go-gitlab-cve-2026-110264-scanner
- Authorized loopback-only Docker firing range for CVE-2026-110264 (Onigmo regex integer-overflow, unauth RCE) research + detection engineering (github_poc): https://github.com/bastet-ai/gitlab-firing-range
- Check whether your self-hosted GitLab version is patched against CVE-2026-110264 (CVSS 10.0 RCE) — companion script for The Homelab Fixer guide. (github_poc): https://github.com/TheGlitchFixer/gitlab-patch-check

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110264 and fix it if it is affected.

What it is: CVE-2026-110264 is a critical vulnerability in Gitlab Gitlab, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-110264 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 7.0.0; fixed in 18.11.13, 19.0.10, 19.1.9, 19.2.9, 19.3.6, 19.4.3, 19.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110264/ (Markdown: https://insights.sbomify.com/CVE-2026-110264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110264
- OSV: https://osv.dev/vulnerability/CVE-2026-110264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110264/
Summaries are generated and may contain mistakes; the official description above is the record.
