CVE-2026-110310 RSA PKCS#1 v1.5 padding oracle via legacy envelope key format downgrade in Amazon S3 Encryption Client for .NET
Attackers can decrypt S3 objects by exploiting a padding oracle in the .NET encryption client's legacy key format handling.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-110310?
CVE-2026-110310 is a medium-severity vulnerability in Amazon.Extensions.S3.Encryption, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A remote user who can read encrypted objects in the S3 bucket can force a padding downgrade by altering the padding scheme recorded in an object's metadata to legacy PKCS#1 v1.5. Since this padding scheme is susceptible to the well-known Bleichenbacher attack, the user can use a PKCS#1 v1.5 padding oracle to recover the RSA-wrapped envelope key and decrypt the object.
To remediate this issue, we recommend that users upgrade to version 3.2.2 or 4.0.3. The 1.x and 2.x lines will not be patched, users of those lines need to migrate to 3.2.2 or 4.0.3.
Which versions are affected by CVE-2026-110310?
How do I fix CVE-2026-110310?
No fix has been published for CVE-2026-110310 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-110310 being exploited?
There is no known exploitation of CVE-2026-110310 in the wild and no public exploit code.