# CVE-2026-110310: RSA PKCS#1 v1.5 padding oracle via legacy envelope key format downgrade in Amazon S3 Encryption Client for .NET

> Attackers can decrypt S3 objects by exploiting a padding oracle in the .NET encryption client's legacy key format handling.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Oct 2026
- **Updated:** 14 Oct 2026

## What is CVE-2026-110310?

CVE-2026-110310 is a medium-severity vulnerability in Amazon.Extensions.S3.Encryption, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A remote user who can read encrypted objects in the S3 bucket can force a padding downgrade by altering the padding scheme recorded in an object's metadata to legacy PKCS#1 v1.5. Since this padding scheme is susceptible to the well-known Bleichenbacher attack, the user can use a PKCS#1 v1.5 padding oracle to recover the RSA-wrapped envelope key and decrypt the object.

To remediate this issue, we recommend that users upgrade to version 3.2.2 or 4.0.3. The 1.x and 2.x lines will not be patched, users of those lines need to migrate to 3.2.2 or 4.0.3.

Weakness: CWE-757 (Selection of Less-Secure Algorithm During Negotiation), CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2026-110310?


## How do I fix CVE-2026-110310?

No fix has been published for CVE-2026-110310 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-110310 being exploited?

There is no known exploitation of CVE-2026-110310 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110310 and fix it if it is affected.

What it is: CVE-2026-110310 is a medium-severity vulnerability in Amazon.Extensions.S3.Encryption, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-110310 in the wild and no public exploit code.

Affected product: Amazon.Extensions.S3.Encryption. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110310/ (Markdown: https://insights.sbomify.com/CVE-2026-110310/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110310
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110310
- OSV: https://osv.dev/vulnerability/CVE-2026-110310

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110310/
Summaries are generated and may contain mistakes; the official description above is the record.
