# CVE-2026-110644: nodejs-whisper through 0.3.1 OS Command Injection via convertToWavType

> Attackers can execute arbitrary OS commands by providing crafted audio file paths to the convertToWavType function in nodejs-whisper.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 14 Oct 2026
- **Also known as:** GHSA-2f48-3555-fpx6

## What is CVE-2026-110644?

CVE-2026-110644 is a critical command injection vulnerability in ChetanXpro nodejs-whisper, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

nodejs-whisper through 0.3.1 contains an OS command injection vulnerability in convertToWavType() that allows attackers to execute commands by supplying crafted audio file paths. Attackers can provide file names containing $() command substitution or closing quotes, which are interpolated into an ffmpeg command run via shelljs exec(), executing OS commands with Node.js process privileges.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-110644?

2 open source packages ship an affected version, including nodejs-whisper.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodejs-whisper` | npm | All versions | 0.4.0 |
| `nodejs-whisper` | npm | All versions | 0.4.0 |

## How do I fix CVE-2026-110644?

Upgrade nodejs-whisper to 0.4.0 or later.

## Is CVE-2026-110644 being exploited?

There is no known exploitation of CVE-2026-110644 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110644 and fix it if it is affected.

What it is: CVE-2026-110644 is a critical command injection vulnerability in ChetanXpro nodejs-whisper, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-110644 in the wild and no public exploit code.

Affected packages and fixed versions:
- nodejs-whisper (npm): affected all versions; fixed in 0.4.0
- nodejs-whisper (npm): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110644/ (Markdown: https://insights.sbomify.com/CVE-2026-110644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110644
- OSV: https://osv.dev/vulnerability/CVE-2026-110644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110644/
Summaries are generated and may contain mistakes; the official description above is the record.
