{"answers":{"affected":"6 open source packages ship an affected version, including fast-uri.","exploited":"There is no known exploitation of CVE-2026-110725 in the wild and no public exploit code.","fix":"Upgrade fast-uri to a fixed version for your release line: 2.4.8, 3.1.9 or 4.2.3.","what":"CVE-2026-110725 is a low-severity vulnerability in fast-uri, published on 20 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-110725 and fix it if it is affected.\n\nWhat it is: CVE-2026-110725 is a low-severity vulnerability in fast-uri, published on 20 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-110725 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fast-uri (npm): affected all versions; fixed in 2.4.8\n- fast-uri (npm): affected all versions; fixed in 2.4.8\n- fast-uri (npm): affected from 3.0.0; fixed in 3.1.9\n- fast-uri (npm): affected from 3.0.0; fixed in 3.1.9\n- fast-uri (npm): affected from 4.0.0; fixed in 4.2.3\n- fast-uri (npm): affected from 4.0.0; fixed in 4.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-110725/ (Markdown: https://insights.sbomify.com/CVE-2026-110725/index.md)","id":"CVE-2026-110725","markdown":"https://insights.sbomify.com/CVE-2026-110725/index.md","name":"CVE-2026-110725","record":{"aliases":["CLSA-2026-1793110552","DEBIAN-CVE-2026-110725","ECHO-3a19-2525-f9c5","GHSA-333x-w4r6-6crp","MINI-23xw-jf86-3wgj","MINI-4849-3r57-fm96","MINI-4c2c-vrm4-8c9w","MINI-6wm3-vp33-xqw2","MINI-hgqr-mm46-rf7j","MINI-q95p-qgvq-wf88","MINI-r94v-7rr6-qvxx","MINI-rxg6-4xjw-v56g","UBUNTU-CVE-2026-110725"],"analysis":null,"analysis_generated_by":null,"assigner":"openjs","cpe":[],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-41","name":"Improper Resolution of Path Equivalence"},{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, when serialize(), normalize(), or resolve() are called with the non-default option reference set to suffix on a reference that has no authority, the emitted relative reference can contain a bare colon in its first path segment without escaping it, even though RFC 3986 forbids that because it makes the string reparse as an absolute URI with a scheme. An application that serializes or normalizes a relative reference with the suffix option and then treats the result as a URI can turn inert input into a live javascript, data, or vbscript URL, a cross-site scripting vector, and the equal() comparison can conflate a scheme-bearing reference with a relative one. Exposure is limited to applications using the non-default suffix reference option. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, avoid the suffix reference option on untrusted input, or percent-encode a colon in the first path segment of the result before treating it as a URI.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"fast-uri vulnerable to scheme injection via an unescaped first-segment colon in suffix references","id":"CVE-2026-110725","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"Security feature bypass in Eclipse Connected Services Platform","id":"CVE-2026-110726"},"packages":[{"ecosystem":"npm","fixed":["2.4.8"],"introduced":["0"],"last_affected":[],"package":"fast-uri","purl":null,"source":"GHSA-333x-w4r6-6crp"},{"ecosystem":"npm","fixed":["2.4.8"],"introduced":["0"],"last_affected":[],"package":"fast-uri","purl":"pkg:npm/fast-uri","source":"GHSA-333x-w4r6-6crp"},{"ecosystem":"npm","fixed":["3.1.9"],"introduced":["3.0.0"],"last_affected":[],"package":"fast-uri","purl":null,"source":"GHSA-333x-w4r6-6crp"},{"ecosystem":"npm","fixed":["3.1.9"],"introduced":["3.0.0"],"last_affected":[],"package":"fast-uri","purl":"pkg:npm/fast-uri","source":"GHSA-333x-w4r6-6crp"},{"ecosystem":"npm","fixed":["4.2.3"],"introduced":["4.0.0"],"last_affected":[],"package":"fast-uri","purl":null,"source":"GHSA-333x-w4r6-6crp"},{"ecosystem":"npm","fixed":["4.2.3"],"introduced":["4.0.0"],"last_affected":[],"package":"fast-uri","purl":"pkg:npm/fast-uri","source":"GHSA-333x-w4r6-6crp"}],"prev":{"headline":"Security feature bypass in Eclipse Connected Services Platform","id":"CVE-2026-110724"},"products":["fast-uri"],"published":"2026-10-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-20","vendors":["fast-uri"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-110725/"}