# CVE-2026-110854: Parse Server before 8.6.97 and 9.10.2-alpha.6 Denial of Service via Unhandled Email Error

> Attackers can crash the Parse Server by triggering unhandled email errors during user registration or password reset requests.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** BIT-parse-2026-110854, GHSA-46jj-qw3p-48fc, GHSA-g2v6-w4hv-64wf

## What is CVE-2026-110854?

CVE-2026-110854 is a high-severity denial of service vulnerability in parse-community parse-server, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server before 8.6.97 and 9.0.0 before 9.10.2-alpha.6 does not handle errors raised while sending verification or password reset emails, causing the server process to exit. A client holding only the public application keys can sign up, request a verification email, or request a password reset while the mail provider rejects, rate limits, or is unavailable, crashing the server.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-110854?

1 open source package ship an affected version, including parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse` | Bitnami | All versions | 8.6.97, 9.10.2 |

## How do I fix CVE-2026-110854?

Upgrade parse to a fixed version for your release line: 8.6.97 or 9.10.2.

## Is CVE-2026-110854 being exploited?

There is no known exploitation of CVE-2026-110854 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110854 and fix it if it is affected.

What it is: CVE-2026-110854 is a high-severity denial of service vulnerability in parse-community parse-server, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-110854 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse (Bitnami): affected all versions; fixed in 8.6.97, 9.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110854/ (Markdown: https://insights.sbomify.com/CVE-2026-110854/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110854
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110854
- OSV: https://osv.dev/vulnerability/CVE-2026-110854

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110854/
Summaries are generated and may contain mistakes; the official description above is the record.
