# CVE-2026-110856: GitPython before 3.2.0 ReDoS via _re_actor_epoch in parse_actor_and_date

> Attackers can cause CPU exhaustion in GitPython by serving repositories with specially crafted commit or tag objects, leading to a denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-110856, ECHO-f57e-0c53-463f, GHSA-f52j-wg44-2h83, GHSA-m64x-33q8-m5h7, MINI-9wcp-3rfq-94mv, UBUNTU-CVE-2026-110856

## What is CVE-2026-110856?

CVE-2026-110856 is a high-severity denial of service vulnerability in gitpython-developers GitPython, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GitPython before 3.2.0 contains a regular expression denial of service vulnerability in the _re_actor_epoch pattern used by parse_actor_and_date on author, committer, and tagger lines. Attackers can serve repositories with commit or tag objects containing long space-filled lines lacking a valid epoch or timezone, causing quadratic backtracking and CPU exhaustion.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-110856?

2 open source packages ship an affected version, including GitPython and gitpython.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `GitPython` | PyPI | All versions | 3.2.0 |
| `gitpython` | PyPI | All versions | 3.2.0 |

## How do I fix CVE-2026-110856?

Upgrade GitPython to 3.2.0 or later.

## Is CVE-2026-110856 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-110856 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110856 and fix it if it is affected.

What it is: CVE-2026-110856 is a high-severity denial of service vulnerability in gitpython-developers GitPython, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-110856 exists.

Affected packages and fixed versions:
- GitPython (PyPI): affected all versions; fixed in 3.2.0
- gitpython (PyPI): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110856/ (Markdown: https://insights.sbomify.com/CVE-2026-110856/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110856
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110856
- OSV: https://osv.dev/vulnerability/CVE-2026-110856

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110856/
Summaries are generated and may contain mistakes; the official description above is the record.
