# CVE-2026-110859: GitPython before 3.2.0 Arbitrary File Read via Head.checkout() Branch Name

> Attackers can read arbitrary files by hosting a repository with a malicious branch name, causing GitPython to leak file contents via error messages.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-110859, GHSA-23mf-xhv8-69c2, GHSA-pv89-gqgv-pcc9, MINI-x8v5-mqqj-5q6q, UBUNTU-CVE-2026-110859

## What is CVE-2026-110859?

CVE-2026-110859 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GitPython before 3.2.0 contains an argument injection vulnerability in Head.checkout() that allows remote attackers to read arbitrary files by supplying a branch name parsed as a git option. Attackers can host a repository whose default branch is named --pathspec-from-file=<path>, causing cloning applications that check out the active branch to leak file contents through GitCommandError messages.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-110859?

2 open source packages ship an affected version, including GitPython and gitpython.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `GitPython` | PyPI | All versions | 3.2.0 |
| `gitpython` | PyPI | All versions | 3.2.0 |

## How do I fix CVE-2026-110859?

Upgrade GitPython to 3.2.0 or later.

## Is CVE-2026-110859 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-110859 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110859 and fix it if it is affected.

What it is: CVE-2026-110859 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-110859 exists.

Affected packages and fixed versions:
- GitPython (PyPI): affected all versions; fixed in 3.2.0
- gitpython (PyPI): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110859/ (Markdown: https://insights.sbomify.com/CVE-2026-110859/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110859
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110859
- OSV: https://osv.dev/vulnerability/CVE-2026-110859

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110859/
Summaries are generated and may contain mistakes; the official description above is the record.
