# CVE-2026-110861: Better Auth drizzle-adapter 1.6.17 before 1.7.7 Rate Limit Bypass via Race Condition

> Remote attackers can bypass rate limits on authentication endpoints by exploiting a race condition in database-backed rate limiting.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-44jh-23m7-hpcf, GHSA-wrjq-vqr4-qw7r

## What is CVE-2026-110861?

CVE-2026-110861 is a medium-severity vulnerability in better-auth, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Better Auth @better-auth/drizzle-adapter and better-auth from 1.6.17 before 1.7.7, and @better-auth/kysely-adapter from 1.6.17 before 1.7.0, contain a race condition in database-backed rate limiting on PostgreSQL where the limit check is not atomic with the counter update. Remote attackers can send bursts of concurrent requests that pass the check together, exceeding configured limits on password sign-in, two-factor verification, one-time code, password reset, and other rate-limited endpoints.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-110861?

6 open source packages ship an affected version, including @better-auth/drizzle-adapter, @better-auth/kysely-adapter and better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@better-auth/drizzle-adapter` | npm | From 1.6.17 | 1.7.7 |
| `@better-auth/drizzle-adapter` | npm | From 1.6.17 | 1.7.7 |
| `@better-auth/kysely-adapter` | npm | From 1.6.17 | 1.7.0 |
| `@better-auth/kysely-adapter` | npm | From 1.6.17 | 1.7.0 |
| `better-auth` | npm | From 1.6.17 | 1.7.7 |
| `better-auth` | npm | From 1.6.17 | 1.7.7 |

## How do I fix CVE-2026-110861?

Upgrade @better-auth/drizzle-adapter to 1.7.7 or later.

## Is CVE-2026-110861 being exploited?

There is no known exploitation of CVE-2026-110861 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110861 and fix it if it is affected.

What it is: CVE-2026-110861 is a medium-severity vulnerability in better-auth, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-110861 in the wild and no public exploit code.

Affected packages and fixed versions:
- @better-auth/drizzle-adapter (npm): affected from 1.6.17; fixed in 1.7.7
- @better-auth/drizzle-adapter (npm): affected from 1.6.17; fixed in 1.7.7
- @better-auth/kysely-adapter (npm): affected from 1.6.17; fixed in 1.7.0
- @better-auth/kysely-adapter (npm): affected from 1.6.17; fixed in 1.7.0
- better-auth (npm): affected from 1.6.17; fixed in 1.7.7
- better-auth (npm): affected from 1.6.17; fixed in 1.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110861/ (Markdown: https://insights.sbomify.com/CVE-2026-110861/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110861
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110861
- OSV: https://osv.dev/vulnerability/CVE-2026-110861

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110861/
Summaries are generated and may contain mistakes; the official description above is the record.
