# CVE-2026-110864: Better Auth 1.5.0-beta.12 before 1.7.7 Authentication Bypass via OAuth Proxy

> Attackers can bypass authentication and take over accounts by forging encrypted profiles when the OAuth Proxy plugin shares a global secret.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-r4xp-prcw-77qf, GHSA-w232-44q8-h37x

## What is CVE-2026-110864?

CVE-2026-110864 is a critical authentication bypass vulnerability in better-auth, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Better Auth from 1.5.0-beta.12 before 1.7.7 contains an authentication bypass vulnerability in the OAuth Proxy plugin that allows unauthenticated attackers to sign in as other users by forging encrypted profiles. When the proxy shares the global secret and cookie-stored state is used, attackers can obtain encrypted state for a fake profile with a victim's verified email to take over the account via implicit linking.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-110864?

2 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | From 1.5.0-beta.12 | 1.7.7 |
| `better-auth` | npm | From 1.5.0-beta.12 | 1.7.7 |

## How do I fix CVE-2026-110864?

Upgrade better-auth to 1.7.7 or later.

## Is CVE-2026-110864 being exploited?

There is no known exploitation of CVE-2026-110864 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110864 and fix it if it is affected.

What it is: CVE-2026-110864 is a critical authentication bypass vulnerability in better-auth, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-110864 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected from 1.5.0-beta.12; fixed in 1.7.7
- better-auth (npm): affected from 1.5.0-beta.12; fixed in 1.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110864/ (Markdown: https://insights.sbomify.com/CVE-2026-110864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110864
- OSV: https://osv.dev/vulnerability/CVE-2026-110864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110864/
Summaries are generated and may contain mistakes; the official description above is the record.
