# CVE-2026-110869: Nodemailer 3.0.0 before 10.0.13 ReDoS via SMTP AUTH Mechanism Detection Regexes

> A malicious SMTP server can cause a denial of service in Nodemailer by triggering quadratic backtracking in regexes during EHLO response parsing.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-110869, ECHO-2ec1-76e4-8d52, GHSA-4ffr-jq9g-5ffx, GHSA-mgrc-5q39-2h34, UBUNTU-CVE-2026-110869

## What is CVE-2026-110869?

CVE-2026-110869 is a high-severity denial of service vulnerability in nodemailer, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nodemailer 3.0.0 before 10.0.13 has a regular expression denial of service in SMTPConnection._actionEHLO, whose four AUTH mechanism detection regexes contain overlapping whitespace sub-patterns that backtrack quadratically. A malicious or man-in-the-middle SMTP server can reply to EHLO with 250-AUTH, a long whitespace run and a non-matching token, blocking the Node.js event loop for tens of seconds to hours before authentication.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-110869?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | From 3.0.0 | 10.0.13 |
| `nodemailer` | npm | From 3.0.0 | 10.0.13 |

## How do I fix CVE-2026-110869?

Upgrade nodemailer to 10.0.13 or later.

## Is CVE-2026-110869 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-110869 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-110869 and fix it if it is affected.

What it is: CVE-2026-110869 is a high-severity denial of service vulnerability in nodemailer, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-110869 exists.

Affected packages and fixed versions:
- nodemailer (npm): affected from 3.0.0; fixed in 10.0.13
- nodemailer (npm): affected from 3.0.0; fixed in 10.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-110869/ (Markdown: https://insights.sbomify.com/CVE-2026-110869/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-110869
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-110869
- OSV: https://osv.dev/vulnerability/CVE-2026-110869

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-110869/
Summaries are generated and may contain mistakes; the official description above is the record.
